Manutenção / Maintenance
Incident Report for Grand Chase History
Resolved
Manutenção finalizada.
Maintenance ended.
Posted Apr 07, 2019 - 17:57 GMT-03:00
Investigating
Fórum sobre manutenção.
Community Board under maintenance.
Posted Apr 07, 2019 - 14:07 GMT-03:00
This incident affected: Forum.