Manutenção / Maintenance
Incident Report for Grand Chase History
Resolved
This incident has been resolved.
Posted Mar 15, 2019 - 19:48 GMT-03:00
Investigating
O serviço de Suporte está sobre manutenção.
Support service is under maintenance.
Posted Mar 13, 2019 - 18:18 GMT-03:00
This incident affected: Suporte.